Upgrade PHP Version for Facebook Support

From WiDirect
Jump to: navigation, search

Older WiDirects will need a software upgrade to support authentication with Google+ accounts. Do not run these commands on new WiDirects. Enabling Google+ login without performing this upgrade will result in an error when users authenticate. This upgrade is no longer required for Facebook support. This upgrade is only required on a WiDirect. No upgrade is required on a WiClient.

su -
yum -y remove php*
rpm -Uvh http://dl.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm
rpm -Uvh http://repo.webtatic.com/yum/centos/5/latest.rpm
sed '/enabled=0/{s/enabled=0/enabled=1/;:a;n;ba}' /etc/yum.repos.d/webtatic.repo > /etc/yum.repos.d/webtatic.repo.1
mv -f /etc/yum.repos.d/webtatic.repo.1 /etc/yum.repos.d/webtatic.repo
yum -y install php php-pear php-mysql php-gd php-xmlrpc php-ldap php-pear-Net-Socket.noarch php-pecl-apc
service httpd restart